How to install specific version of node?

$ brew tap homebrew/versions

$ brew search node

$ brew install homebrew/versions/node5

Advertisements

NPM node module connect problem

I had a problem to find module on npm list which was ‘ejs’ while I am trying to integrate React along with Express.

Recently, ejs is no longer coming along with Express on NPM. What you need to do is

npm install ejs -g

then if it is still having a problem to find ejs, link it using

npm link ejs

Enjoy!

Update NPM/NODE all the time!

Grrr..

I was working on React study with using gulp. I usually act on yeoman/grunt but I guess gulp is rising and need to use it.

So far it was totally okay to use gulp and serving ,at some point, on gulp brings whole knocked out.

The problem was solved next day with updating all packages globally.

Remember, When you use evolving platform/library, always do update npm and node.

Here is useful stackoverflow link.

http://stackoverflow.com/questions/8191459/how-to-update-node-js

Enjoy!

Good Git links

Even though I have kept using Git, sometimes it confuses me on which command I should put. I, however, don’t want to bother myself to look into a few hundreds pages book to just a line.

For some who has same issues as me,

Here are useful links

  1. Atlassian simple work flow

http://blogs.atlassian.com/2014/01/simple-git-workflow-simple/

  1. Git the simple guide

http://rogerdudler.github.io/git-guide/

Enjoy!